Server Requirements

WordPress requirements

In order to proceed with the theme installation, you need to make sure you have the latest version of WordPress on your self-hosted site.
If you are new to WordPress, I would recommend learning a little bit about it before you get started. Below is helpful Resources to get you started with WordPress:

Theme requirements

The theme can work all almost servers, but we recommend following server settings:
  • PHP : Version 5.4 or greater, The recommended version: 7.x
  • MySQL: Version 5.6 or greater.
  • upload_max_filesize: 16 MB or greater.
  • memory_limit: 64MB or greater. The recommended is 128M or 256M.
  • max_input_vars: The minimum value is 2000 but the recommended is 10000.

Server requirements

There are several methods to check server requirements. We explain the most common method: WP-ServerInfo plugin
The plugin allows you to easily check almost all the server configs. Install the plugin like any other WordPress plugin then follow below steps:
  1. 1.
    From your dashboard, go to the Dashboard -> WP-ServerInfo page. It shows some general information about your server.
  2. 2.
    To see all server information, click on Display PHP Information and Display MYSQL Information.
Copy link
On this page
WordPress requirements
Theme requirements
Server requirements